Recall CODESYS V3.5 SP17 Patch 5

CODESYS V3.5 SP17 Patch 5 was released on October 28, 2022.

Unfortunately, this version contains a bug in the compiler related to parameter lists in libraries. Under certain circumstances, values changed by the user are not considered when the application is created. This can affect both values changed by the user and default values. The user, however, does not receive any indication of this problem. This can lead to unpredictable errors in the execution of the application. For example, data from buffers could be incompletely received or sent. This may also prevent the fieldbus from working correctly.

We are working on a corrected version and will inform you via our release channels as soon as it is available. We strongly recommend that you then replace all versions of V3.5 SP17 Patch 5 with the corrected version.

Please accept our apologies for any inconvenience this may cause.